oztoppy Forum
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment   Page 1 of 2      1   2   Next
DeltaMikeCharlie

Mostly Harmless
Registered:
Posts: 316
Reply with quote  #1 
The user "Zarquon" sent me a PM asking about NASMount and requesting that I post it to the forum:

Quote:
Originally Posted by Zarquon

Please can someone help me with this query regarding NASmount.tap
I'm either lost, confused or just drowning.

I have a TRF2400, a windows 10 PC and a NAS hanging off my router.

I have installed TAPtoDate.tap and NASmount.tap on the 2400 using filezilla.
the NAS is mapped - on the PC as \\10.0.0.105\public and has the following folders

\Movies
\Pictures
\Radio
\TV

When I connect to the 2400 from the PC and look under File Management/TAP files/autostart I can see both taps are running.

I have edited the NASmount.ini file with the following settings
NAS IP-Address=10.0.0.105
NAS MAC-Address=
Local Folder Name=NAS-Share
Remotefolder mediaFiles=/public/movies
Remotefolder MP3Files=
Remotefolder PhotoFiles=/public/pictures
Remotefolder DataFiles=
Mountoptions=-osoft,intr,tcp,rsize=65535
NAS Boottime=30
Automount=1
Ping Wait=3
Ping Gap=30
MountDelay=30
NAS Recording=0
Timerdelay=0
SilentMode=0

I start the PVR and do not see any changes anywhere in the menu system - I can't find the Local folder name anywhere and the only way i know the taps are running is to remote in from the PC.

This line is from the NASmount post

"It will mount up to four directories (one for Videos, one for Pictures, one for MP3 and one for Recording) from up to 10 NAS-Servers to the local Folders on the SRP."
  1. what is the SRP
  2. where do I find the 'Local Folders' - I've looked in every place in the Menu system
  3. I just upgraded to version 2.16 and nothing has changed.
0
DeltaMikeCharlie

Mostly Harmless
Registered:
Posts: 316
Reply with quote  #2 
"SRP" refers to the PVR.  This is the European model prefix, but the same TAPs will work for our "TMS" machines without modification.

Do you have the NFS protocol enabled on your NAS?

To see if a TAP is running (without using another TAP) go into the recordings list on the PVR, use the ">>" or "<<" buttons to navigate to "Program Files".  Non-running TAPs will be white, running TAPs will be green.
0
Zarquon

Junior Member
Registered:
Posts: 3
Reply with quote  #3 
DeltaMikeCharlie -Thankyou for posting for me and for the 2 suggestions.

yes, the Taps are green but still cannot find NAS-Share anywhere

I did realise 1 mistake I was doing - I was using left and right on the circle button not the << or >>

now to check on NFS - will let you know


0
James

Member
Registered:
Posts: 37
Reply with quote  #4 
Yes, make sure your NAS supports NFS. When I first dabbled with it I used a freeware windows NFS program
which was pretty easy to get going. Then I branched out into linux. I took me a few goes but with help from
the NAS' software forum I got it running. I use the ff or rw key to navigate to the file list. It's not hidden
anywhere out of site.

Here is my Nasmount.ini,

NAS IP-Address=192.168.0.105
NAS MAC-Address=
Local Folder Name=HTPC3
Remotefolder MediaFiles=/export/Lounge
Mountoptions=-osoft,intr,tcp,rsize=65535,nolock
NAS Boottime=30
Automount=1
Ping Wait=3
Ping Gap=30
MountDelay=30
NAS Recording=0
Timerdelay=0
SilentMode=0
Logfile=1
Remotefolder MP3Files=

Here is a picture of my NAS config,

NasMount.jpg 
As you can see I had to add /export to the path in my .ini file. This was the key to get my setup working.

James

0
Zarquon

Junior Member
Registered:
Posts: 3
Reply with quote  #5 
James
Thanks for the time spent on your reply - it would seem that I didn't have NFS running on my NAS - have started that in Windows 10 and my Blackarmor 110 NAS. I hadn't set it up before as I just mapped to it so didn't need it. Now trying to setup a user account for the topfield in the NAS but the NAS wants a password from the topfield. trying to work on that at the moment.

Once again many thanks to you and DeltaMikeCharlie

0
James

Member
Registered:
Posts: 37
Reply with quote  #6 
I should of added that a successful connection will be indicated by a small network icon seen in the top r/h side of your tv screen.
The icon can be greyed out indicating an issue as well. The icon will appear about 30 seconds after the tap is loaded.The icon then disappears after a few seconds.
I don’t recall ever having to set up a password. I would think if you gave the NFS shared folder the correct permissions
You wouldn’t have too?
0
Zarquon

Junior Member
Registered:
Posts: 3
Reply with quote  #7 
James
Been away for 2 weeks - finally got on and read your post - still trying to work out if my NAS is using NFS - will now look at permissions as well - Thanks

0
keith_leitch

Senior Member
Registered:
Posts: 742
Reply with quote  #8 
I'm not sure if anyone can help, because I'm struggling with settings that are probably related to my NAS server (a TheCUS N2310).

NASMount is able to successfully mount the server, but so far only using the inaccessible system mount-point that the documentation seems to say is a parent to the more usable folders. Here are some details.

My only "successful" settings so far (NAS mounts, but I cannot view or access any folders from the PVR):


NAS IP-Address=10.1.1.3
NAS MAC-Address=
Local Folder Name=@Shared
Remotefolder MediaFiles=
Remotefolder MP3Files=
Remotefolder PhotoFiles=
Remotefolder DataFiles=/raid0/data/_NAS_NFS_Exports_
Mountoptions=-t nfs
NAS Boottime=60
Automount=1
Ping Wait=3
Ping Gap=30
NAS Recording=0
MountDelay=5
Timerdelay=0
SilentMode=0
Logfile=1



The NAS documents these NFS mount-points:


NFS3 Mount point: /raid0/data/_NAS_NFS_Exports_/NAS_Public
NFS4 Mount point: /NAS_Public


However, when I try to add NAS_Public to my path, the mount fails.

I have the server set up as follows, which I thought would be ready for the PVR:

Capture.jpgHowever, I can't get anything to mount at the NAS_Public folder or beneath.

According to my NAS, I should be able to use the -t nfs option (for NFS3) or the -t nfs4 option as follows:


The _NAS_NFS_Exports_ is a system folder which cannot be accessed.
Please refer to the following examples of how to mount a network device.

NFS3: mount -t nfs 192.168.2.254:/raid0/data/_NAS_NFS_Exports_/SAMPLE /mnt/sample
NFS4: mount -t nfs4 192.168.2.254:/SAMPLE /mnt/sample


However, using -t nfs4 the mount has always just failed. I'm assuming the 2460 does not support it. Using -t nfs, I cannot reach the NAS_Public folder, or anything beneath it.

My goal is to set up a shared folder for use by both the Toppies and my Media PC, so that they can access each other's files. I may or may not want to record to that shared folder, but I need to cross this bridge first.

Any advice?


0
James

Member
Registered:
Posts: 37
Reply with quote  #9 
Keith,

What happens if you use the default mount settings - Mountoptions=-osoft,intr,tcp,rsize=65535,nolock
0
keith_leitch

Senior Member
Registered:
Posts: 742
Reply with quote  #10 
Thanks for the reply. I should have mentioned that I originally had these in, but there was no difference. I took them out to experiment more systematically. My understanding is that they are more about streaming from the device, anyway, and less about connecting to them.
0
James

Member
Registered:
Posts: 37
Reply with quote  #11 
Do you have a menu option in your NAS like my picture above where you can specify who can mount and access the share plus the extra options?
When you bring up the file explorer on the toppy I assume you can see the NAS but the list is blank? If so can you press the green button on the
remote a few times whilst on that screen and then look at the NAS and see if new folders have been generated.
0
keith_leitch

Senior Member
Registered:
Posts: 742
Reply with quote  #12 
Firstly, I have set NFS file sharing as follows:

Capture.jpg 
I've set the top-level NAS_Public directory to share publicly. As you can see, the subdirectories inherit that public setting:

Capture1.jpg 
Regarding what I see on the Toppy, I have two answers:

  • When I try to connect NASMount to the folders I "want" (i.e. the /raid0/data/_NAS_NFS_Exports_/NAS_Public/Files/Ent/DataFiles folder pictured above), the mount fails, so I cannot see anything on the Toppy.
  • Only when I try to connect it to the root level above NAS_Public (/raid0/data/_NAS_NFS_Exports_) does the mount succeed. The mount-point (@Shared) then appears on the Toppy file explorer. However, when I enter it, I cannot see any subfolders, and pressing the Green button has no effect. No new folders are generated, and none appear when I access the system from outside the Toppy. That could imply a lingering permissions issue. Is there anything else I can try to resolve that?

0
James

Member
Registered:
Posts: 37
Reply with quote  #13 
Sorry Keith, out of idea's at the moment. Your NAS' 'modify folder' seems to lack a few options compared to mine.
0
keith_leitch

Senior Member
Registered:
Posts: 742
Reply with quote  #14 
No problem. I've been trying off and on for years to get this TAP to work for me. I thought a new NAS might solve the problem, but I guess not.

Maybe there is some way to hardlink the user folders I want underneath the only system folder I can access... ???
0
James

Member
Registered:
Posts: 37
Reply with quote  #15 
Keith,
Just to confirm the TAP is working, can you try FreeNFS. It's a windows NFS program. Quite easy to setup and run from a PC.
This is how I first started with the TAP.
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.